Installare i driver ATI Catalyst 11.6 su Ubuntu Natty 11.04




VN:F [1.9.22_1171]
VOTA L'ARTICOLO
Rating: 0.0/5 (0 votes cast)

Pochi giorni fa sono stati rilasciati da AMD i nuovi driver ATI Catalyst 11.6 che, oltre ad un aumento generale delle prestazioni, introduce delle novità. Una di queste è la funzione Steady Video il quale è un’esclusiva AMD che grazie ad algoritmi avanzati rende migliore l’esperienza video, sono molti altri i miglioramenti sopratutto per utenti windows e sono consultabili sulla pagina ufficiale.

Ma vediamo subito come averli su Ubuntu Natty 11.04. Per prima cosa bisogna eliminare la precedente versione dei driver Catalyst nel caso li abbiate installati, per farlo basta questo comando:

sudo apt-get remove --purge fglrx*

Adesso dobbiamo creare una cartella e scaricare i driver all’interno di essa, per farlo digitiamo questi comandi da terminale:


cd && mkdir ati
cd ati
wget http://www2.ati.com/drivers/linux/ati-driver-installer-11-6-x86.x86_64.run
chmod +x ./ati-driver-installer-11-6-x86.x86_64.run

Ora, sempre da terminale digitiamo il comando seguente per creare i pachetti .deb:

sudo sh ati-driver-installer-11-6-x86.x86_64.run --buildpkg Ubuntu/natty

Siamo pronti, ora non ci resta che installarli digitando:

sudo dpkg –i *.deb

Al termine dell’installazione occorre che la scheda video sia rilevata correttamente, per farlo digitiamo quest’ultimo comando:

sudo aticonfig –initial –f

Riavviate il pc e troverete i driver ATI Catalyst 11.6 installati nel vostro sistema. È possibile installare i driver anche sulle due distribuzioni precedenti alla 11.04 sostituendo i seguenti comandi a quello usato precedentemente..

Per Ubuntu 10.10:

sudo sh ati-driver-installer-11-6-x86.x86_64.run --buildpkg Ubuntu/maverick

 

 

Per Ubuntu 10.04:

sudo sh ati-driver-installer-11-6-x86.x86_64.run --buildpkg Ubuntu/lucid

 

 





  • Francesco
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)

    Ciao, ho provato a seguire la guida ma ho un problema al primo comando, quando tento di rimuovere la vecchia versione mi dice:
    E: Impossibile trovare il pacchetto –purge

    Come mai? Cosa sbaglio?

  • ValeDelu
    VN:F [1.9.22_1171]
    Rating: 0 (from 0 votes)

    Non sbagli niente, c’è un’errore di scrittura nell’articolo, deve esserci il doppio trattino prima di purge e buildpkg, correggerò subito.

  • asdrubale
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)

    ciao!! grande articolo…xò ho un problema…riesco a fare tutto senza errori ma quando provo a lanciare da terminale il comando “sudo aticonfig –initial –f” mi risponde con “sudo: aticonfig: command not found
    “… come posso fare??

  • Giacomo
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)

    Salve a tutti,,,,,,,,il solito che non ci prende niente………mi date una mano perfavore??

    giacomo@IZ5OPVPORTATILE:~/ati$ sudo dpkg –i .deb
    dpkg: error: necessaria un’opzione che indichi un’azione

    Usare dpkg –help per un aiuto sull’installazione e la rimozione dei pacchetti [*];
    Usare “dselect” o “aptitude” per un’interfaccia alla gestione dei pacchetti;
    Usare dpkg -Dhelp per l’elenco delle opzioni di debug per dpkg;
    Usare dpkg –force-help per l’elenco delle opzioni di forzatura;
    Usare dpkg-deb –help per un aiuto sulla manipolazione dei file *.deb;

    Le opzioni indicate con [*] producono output prolisso – creare una pipe con “less” o “more”.

    Grazie mille ,,,speriamo di imparare qualcosa piano piano….

    • http://www.marcocretarola.com kajapezz8
      VN:F [1.9.22_1171]
      Rating: 0 (from 0 votes)

      manca l’asterisco, ripeti l’operazione con
      sudo dpkg –i* .deb

      • Giacomo
        VA:F [1.9.22_1171]
        Rating: 0 (from 0 votes)

        Magari!!!!! è soltanto un’errore di trascrizione !! in verità il comando è giusto …come quello che mi hai suggerito tu…mi sfuge qualcosa?!?!?!?!?! AIuto!!!!

  • Antonio
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)

    c’è un errore di spaziatura nell’articolo, il comando corretto è:
    sudo dpkg –i *.deb
    e non:
    sudo dpkg –i* .deb

    • http://www.marcocretarola.com kajapezz8
      VN:F [1.9.22_1171]
      Rating: 0 (from 0 votes)

      Corretto…

      Grazie Mille

  • asdrubale
    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)

    Ciao scusate ma anch’io ho lo stesso problema dando il comando: sudo dpkg –i *.deb
    il terminale mi risponde così :
    nick@nick:~/ati$ sudo dpkg –i *.debdpkg: errore: necessaria un’opzione che indichi un’azione
    Usare dpkg –help per un aiuto sull’installazione e la rimozione dei pacchetti [*];Usare “dselect” o “aptitude” per un’interfaccia alla gestione dei pacchetti;Usare dpkg -Dhelp per l’elenco delle opzioni di debug per dpkg;Usare dpkg –force-help per l’elenco delle opzioni di forzatura;Usare dpkg-deb –help per un aiuto sulla manipolazione dei file *.deb;
    Le opzioni indicate con [*] producono output prolisso – creare una pipe con “less” o “more”.

    come posso fare??

    • Andrea
      VA:F [1.9.22_1171]
      Rating: 0 (from 0 votes)

      Ciao, devi sostituire il trattino prima della “i” con il pulsante da tastira “-”.
      Quello nel testo evidentemente non lo riconosce.